Problems with HP Port Replicator 3005pr

I had some issues with the screens and usb devices after upgrading from Windows 8 to Windows 10 the other day. It was only one screen that was working and none of the USB devices where working.

When trying to update the driver for HP Port Replicator 3005 pr I got the following error message: “A previous uninstall of HP Port Replicator Software is not yet complete. Please reboot your computer and run this installer again to installation.”

I tried several solutions to solve the issue but none of the ones I found on the internet helped me. Most of the problems was solved with the compability mode but for some reason that was not good enough for me. After some troubleshooting I discovered that it failed during the update of the displaylink software. I then downloaded the Display Link software manually and tried to run the setup. I got a message saying that the installation had failed (I don’t have a screenshot or the correct words).

When I did the complete uninstall of the DisplayLink software I was able to install the port replicator driver. The uninstall software can be found here. The software is named “DisplayLink Installation Cleaner” and starts a command window where you will press enter to remove the old software.

Advertisements

6 thoughts on “Problems with HP Port Replicator 3005pr

  1. Have you had any other problems with this particular port replicator? I have had my start menu and Metro apps stop working from time to time, immediately after connecting the port replicator. The problem persists even after I disconnect from it. It seems there are some drivers that are interfering with Windows 10, but I can’t figure out how to reverse it. It could also have to do with the monitor (Samsung B2240W).

    1. I havent had any other issues than what I mentioned. But the first step to troubleshoot would be to disconnect everything from the replicator and connect the computer. If nothing stops to work and seems normal I would connect device by device to the replicator and see when you get an issue.

  2. Anyone out there have issues with (Hot Docking) seems like when we have users just disconnect the USB with the laptop powered on the ICON come back different sizes. Seem to fix if you log off and back on, but they are use to hot docking.

  3. Just found (you?) link this from the HP support forums… after hours of trying and searching I stumbled across this which worked straight away! Thanks!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s